VMware Aria Operations for logs upgrade is stuck at 'upgrade pending' though the UI shows expected version
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VMware Aria Operations for logs upgrade is stuck at 'upgrade pending' though the UI shows expected version

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Article ID: 382704

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • Upgrading 'Aria Operations for logs from 8.14 to 8.16.1' gets stuck at 'Upgrade Pending'.

  • All the nodes within the cluster reports as 'Upgrade Pending'.
  • The '/storage/core/loginsight/config/loginsight-config.xml' still reports previous version.
  • The /var/log/vmware/loginsight/upgrade.log file reports a successful upgrade.

Environment

VMware Aria Operations for logs 8.14 and later

Cause

The upgrade could not be marked as 'Complete' as the EULA was set to false.

Resolution

Manually set the EULA to 'True' & the upgrade state to 'Complete'.

Note: Verify that the previously taken snapshot exists.

  1. Open a console or SSH session to the Primary node of the Log Insight cluster and log in as root.
  2. Switch the current working directory by running this command:
    • cd /usr/lib/loginsight/application/lib/apache-cassandra-*/bin

  3. Open the Cassandra CQL shell by running this command:
    • cqlsh-no-pass

  4. At the cqlsh> prompt, select the logdb keyspace by running this command:
    • cqlsh> use logdb;

  5. Determine the status of all historic upgrades by running this command:
    • lisuper@cqlsh:logdb> select * from upgrade_status;
    • Example output:
      •         version         | eula_accepted |         finished      | master_id    |                            pak_file_name                                 |                                        pak_file_url                                      |        started        |       status
        -----------------+---------------+---------------+--------------------------------------+-------------------------------------------------+-------------------------------------------------------------------------------------+---------------+--------------------------+---------
         8.16.1-24029724 |         False      |             0              |    UUID        | VMware-vRealize-Log-Insight-8.16.1-24029724.pak | /upgrade-internal?getPakFile=&pakDownloadToken=UUID | 1731392653985 |      Pending 
         8.10.2-21638564 |          True       | 1686580008498 |    UUID        | VMware-vRealize-Log-Insight-8.10.2-21638564.pak | /upgrade-internal?getPakFile=&pakDownloadToken=UUID | 1686579046386 |      Complete
         8.14.1-22806512 |          True       | 1731393839801 |    UUID        | VMware-vRealize-Log-Insight-8.14.1-22806512.pak | /upgrade-internal?getPakFile=&pakDownloadToken=UUID | 1731392768141 |      Complete
         8.12.0-21696970 |          True       | 1693557508431 |    UUID        | VMware-vRealize-Log-Insight-8.12.0-21696970.pak | /upgrade-internal?getPakFile=&pakDownloadToken=UUID | 1693554055944 |      Complete

  6. Identify the highest version number from the above list.

  7. Mark the cluster upgrade status to Complete & EULA to True using the version number from step 5:
    • lisuper@cqlsh:logdb> update upgrade_status SET eula_accepted = True where version = '8.16.1-24029724';
    • lisuper@cqlsh:logdb> update upgrade_status SET status = 'Complete' where version = '8.16.1-24029724';

  8. Determine the status by running this command:
    • lisuper@cqlsh:logdb> select * from upgrade_status;
    • Example output:
      •         version         | eula_accepted |         finished      | master_id    |                            pak_file_name                                 |                                        pak_file_url                                      |        started        |       status
        -----------------+---------------+---------------+--------------------------------------+-------------------------------------------------+-------------------------------------------------------------------------------------+---------------+--------------------------+---------
         8.16.1-24029724 |          True       |             0             |    UUID        | VMware-vRealize-Log-Insight-8.16.1-24029724.pak | /upgrade-internal?getPakFile=&pakDownloadToken=UUID | 1731392653985 |      Complete 
         8.10.2-21638564 |          True       | 1686580008498 |    UUID        | VMware-vRealize-Log-Insight-8.10.2-21638564.pak | /upgrade-internal?getPakFile=&pakDownloadToken=UUID | 1686579046386 |      Complete
         8.14.1-22806512 |          True       | 1731393839801 |    UUID        | VMware-vRealize-Log-Insight-8.14.1-22806512.pak | /upgrade-internal?getPakFile=&pakDownloadToken=UUID | 1731392768141 |      Complete
         8.12.0-21696970 |          True       | 1693557508431 |    UUID        | VMware-vRealize-Log-Insight-8.12.0-21696970.pak | /upgrade-internal?getPakFile=&pakDownloadToken=UUID | 1693554055944 |      Complete

  9. Restart the log insight service
    • service loginsight restart

  10. The UI should now show as Monitor