DNS "Address resolution took too long"
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DNS "Address resolution took too long"

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Article ID: 382642

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Updated On:

Products

VMware Live Recovery

Issue/Introduction


In Site Recovery Manager 8.8/VMware Live Site Recovery 9.0.x, Domain Name Service (DNS) resolution may take longer than usual on failover and cause recovery times to increase.

DNS Caching can help DNS resolution time by allowing domain names to resolve internally via caching, instead of resolving each query with an external DNS server.

You may find logs are filled with messages such as, when performing a failover:

VMware-dr.log: 

2024-11-03T18:47:20.278Z warning vmware-dr[01871] [SRM@6876 sub=IO.Connection opID=87554370] Address resolution took too long; <resolver p:0x00007f52c8052200, '<target domain name entity>', next:(null)>, async: true, duration: 5005msec
2024-11-03T18:47:20.280Z warning vmware-dr[01333] [SRM@6876 sub=IO.Connection opID=0059ab20] Address resolution took too long; <resolver p:0x00007f52c809eca0, '<target domain name entity>', next:(null)>, async: true, duration: 5007msec
2024-11-03T18:47:20.282Z warning vmware-dr[01959] [SRM@6876 sub=IO.Connection opID=bb39bfc6] Address resolution took too long; <resolver p:0x00007f52c8050be0, '<target domain name entity>:443', next:(null)>, async: true, duration: 5009msec
2024-11-03T18:47:20.286Z warning vmware-dr[01863] [SRM@6876 sub=IO.Connection opID=c0a16e01] Address resolution took too long; <resolver p:0x00007f52c8009120, '<target domain name entity>:443', next:(null)>, async: true, duration: 5012msec
2024-11-03T18:47:20.288Z warning vmware-dr[01538] [SRM@6876 sub=IO.Connection opID=2abdd32a] Address resolution took too long; <resolver p:0x00007f52c808d880, '<target domain name entity>:443', next:(null)>, async: true, duration: 5014msec
2024-11-03T18:47:20.289Z warning vmware-dr[01934] [SRM@6876 sub=IO.Connection opID=c0a3ff78] Address resolution took too long; <resolver p:0x00007f52f46c18f0, '<target domain name entity>:443', next:(null)>, async: true, duration: 5014msec

Environment


VMware Site Recovery Manager 8.8
VMware Live Site Recovery 9.0, 9.0.1, 9.0.2
 

Cause

Starting in Photon OS version 4, the appliance OS that runs Site Recovery Manager 8.8 through VMware Live Site Recovery 9.0.x, DNS Caching, is not enabled by default. This was a feature that was enabled by default in previous versions of Photon OS.

This is caused by a formatting change that exists in the /etc/nsswitch.conf on the operating system.

Resolution

This will be resolved in an upcoming release of VLSR (VMware Live Site Recovery), and this KB will be updated to reflect the version once it is released.

Please see below how to workaround this issue on either SRM 8.8 and VLSR 9.0.x


Workaround:

Perform these steps on all your affected SRM/VLSR appliances. 

1. SSH into the SRM appliance  

2. Edit and Add resolve before "dns" in /etc/nsswitch.conf file, as shown below.

root@vlsr [ ~ ]# cat /etc/nsswitch.conf
#       Begin /etc/nsswitch.conf

        passwd: files
        group: files
        shadow: files

        hosts: files resolve dns
        networks: files

        protocols: files
        services: files
        ethers: files
        rpc: files
#       End /etc/nsswitch.conf

3. Ensure the file is saved if you used an editor (such as VI) to edit the file. You can confirm with a cat /etc/nsswitch.conf as seen above.

4. Restart the appliance to have the changes take effect for all components on the appliance.

Additional Information