Unable to access Endpoint Detection and Response (EDR) console after upgrading to Version 4.10
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Unable to access Endpoint Detection and Response (EDR) console after upgrading to Version 4.10

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Article ID: 382604

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Updated On:

Products

Endpoint Detection and Response

Issue/Introduction

Unable to access EDR web and command line console (ssh) after upgrading to Version 4.10 

Environment

Endpoint Detection and Response Version 4.10

Cause

Delay in binding the IP address causing service failure . (Network Manager Device Configuration Patch).

Resolution

EDR console is inaccessible after upgraded to 4.10 Version, nginx and sshd service manually needs to be started to gain access of EDR console.
Please contact support to start these services manually.

The issue reappears upon reboot if patch is not installed on EDR appliance.

Hotfix (atp-patch2-4.10.0-1) is released to address this issue permanently, follow below steps to install hotfix on EDR Version 4.10 

1. Login to admin account on EDR (Version 4.10) via ssh or Access EDR via serial console port if unable to ssh. 

sedr> patch list

Available Patches
atp-patch1-4.10.0-1
atp-patch2-4.10.0-1
sedr> patch download atp-patch2-4.10.0-1
sedr> patch install atp-patch2-4.10.0-1

.........

Please reboot the appliance once HF installation is done..
Verifying        : atp-patch2-4.10.0-1.x86_64                             1/1

Installed:
  atp-patch2-4.10.0-1.x86_64
Complete!
Patch installation Success!
Function: do_install returned success
sedr>

 

2.Reboot EDR appliance 

sedr> reboot

 

EDR console and ssh should be accessible persistently upon every reboot without any manual intervention.