iReporter: Report Timing Out - java.net.SocketTimeoutException: Read timed out

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Article ID: 38255

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Updated On:

Products

DX Infrastructure Management NIMSOFT PROBES

Issue/Introduction

Symptoms:

iReporter: Report Timing Out - java.net.SocketTimeoutException: Read timed out

Environment:  

iReporter

Cause:

IReport time is not correctly set

Resolution:

There is a timeout value in iReport that can get adjusted in Tools –> Options –> iReport –> JasperReports Server Repository. By default this value is set to zero which indicates no timeout, but it still does. Adjusting this setting to 100,000 resolved the problem.
 
Another value is in <Nimsoft_Home_Dir>\probes\services\wasp\webapps\jasperserver-pro\WEB-INF in a file called web.xml
 
There is a section that looks like this:
<session-config>
    <!-- Default to 20 minute session timeouts -->
    <session-timeout>120</session-timeout>
</session-config>
 
By default, Nimsoft has a value of 720 in there. Bumping it to 10000 seems to have resolved the problem when running the report from a web session as opposed to iReport.
 
Additional Information:
This timeout value along with the setting in iReport is related to a web services call that is made to apache. If the timeout is reached the axis service in apache closes the request.

Environment

Release: NMSASE99000-6.5-Monitoring Solution-Application Server-for Enterprise
Component: