App service not available on HTTPS - error cannot obtain resource
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App service not available on HTTPS - error cannot obtain resource

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Article ID: 382435

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

After upgrade or migration or a change on the server, unable to connect to the app Clarity server, ERR_CONNECTION_REFUSED on HTTPS only, whilst HTTP is working

In logs, error message:

2024/11/16 01:37:22.561  |  SEVERE: Failed to initialize component [Connector["https-openssl-nio2-443]]
2024/11/16 01:37:22.561  |  org.apache.catalina.LifecycleException: Protocol handler initialization failed
2024/11/16 01:37:22.565  |  Caused by: java.lang.IllegalArgumentException: Cannot obtain resource for specified location: [D:\Clarity\SSLCertificate\sslkeystore.jks]: no readable file, classloader resource, or this is not a resolvable URI
2024/11/16 01:37:22.565  | at org.apache.catalina.startup.CatalinaBaseConfigurationSource.getResource (CatalinaBaseConfiguratiuonSource.java:115)

Environment

Any Supported Clarity Release

Cause

Certificate folder is not at the specified location or permissions are not provided

Resolution

  1. Ensure the certificate folder is correctly copied at the location indicated in CSA together with the keystore file
  2. Ensure correct permissions are provided to access this keystore file
  3. Restart all services