SD Agent stops abruptly when receiving a SD Job Container
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SD Agent stops abruptly when receiving a SD Job Container

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Article ID: 382422

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

Sometimes when receiving a SD Job Container, sdagent stops abruptly.
Last lines in TRC_USD_SDAGENT*.log are :

241024-13:55:18.7872149L|008040|00002ba4|SDAgent   |SDAgent         |sdjobclientif.cpp   |002568|NOTIFY | Get container <container_uuid>
...
241024-13:55:19.0129490L|008040|00002ba4|SDAgent   |SDAgent         |sdsmmsg.cpp         |001247|INFO   | buildInboundMessage: HeaderSize:74, BodySize:8067, Header:<header uuid="<UUID>" bodyFormat="plain"/>
241024-13:55:19.0129694L|008040|00002ba4|SDAgent   |SDAgent         |sdsmmsg.cpp         |001325|DETAIL | Plain Message.
241024-13:55:19.0130771L|008040|00002ba4|SDAgent   |SDAgent         |sdsmmsg.cpp         |001346|DETAIL | ** buildInboundMessage end **

Environment

Client Automation 14.5 with CU6 or CU7

Cause

This problem occurs when these both conditions are met :

  • Trace level is set to DETAIL for SDAgent
  • SD Agent receives a SD Job Container with a body size equal to 8067 characters

Resolution

Workaround :

Remove the trace DETAIL level for SD Agent :
cftrace -c set -l ERROR -s 2000 -f USD -pp SDAgent -ln 2

 

Solution :

Open a case at Broadcom Technical Support and ask for fix T533398
This fix could be applied on Agent 14.5 CU6 or CU7
It delivers following file :
Name    : cfTrace.dll
Size : 115 712 bytes
Date : 13 November 2024
Version : 14.5.0.601