HCX DR replication of a VM fails with "Interconnect appliance is not deployed"
book
Article ID: 382412
calendar_today
Updated On:
Products
VMware HCX
Issue/Introduction
When completing replication the following ERROR is generated : "Interconnect appliance is not deployed"
Environment
HCX
Cause
For HCX Disaster Recovery (DR) to be enabled on a VM, it must first be enabled on the compute profile (source and destination).
Resolution
From the HCX Manager UI, navigate to Interconnect > Compute Profiles > select Edit from the bottom left.
Edit the required Compute Profile, select the cluster that this VM is residing in to enable the selected VMware HCX services for that cluster.
Proceed through the steps to the end. Ensure this option is applied on both the source and destination Compute Profiles, then save the changes.
Resync the Service Mesh.
If the above steps have failed to resolve the issue please open a support case with Broadcom Support and refer to this KB article. For more information on creating a case, see Creating and managing Broadcom support cases.