Unable to delete an cancelled discovery job
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Unable to delete an cancelled discovery job

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Article ID: 382411

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

A device discovery job has been defined and executed. The job has a large network scope and the completion of the scan is taking time to complete.

The CA PAM adminstrators cancel this device discovery job (for what ever reason) , but are unable to delete this scan job from the CA PAM UI. Basically, they would like to delete the scan jobs that have the status as cancelled.

The jobs that have the status as completed can be removed from the UI using the delete button.

Environment

CA PAM : Release 4.2

Cause

Currently, the delete button only removes the scan jos that are completed successfully.

The most likely cause for the scan job not being deleted is that the job is cancelled without being completed and the process that is actually doing the device discovery is interupted and the process is not getting killed when the job is being deleted from the CA PAM UI.

Resolution

Please open a support ticket with Broadcom and the support team would have to connect to the backend using the SSH_Debug patch and manually kill the 'nmap' process to remove the scan job from the CA PAM UI that has been cancelled.