Restart of the snmp service takes a long time and snmp is not listening on configured port
search cancel

Restart of the snmp service takes a long time and snmp is not listening on configured port

book

Article ID: 382407

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

service snmpd restart

  • SNMP is not listening on port 161 when checked using the following command:

ss -tuln | grep 161

  • Running the command "rpm -qa" returns no output.

Environment

Cloud Director 10.5.1

Cause

This issue can occur if the rpm database is damaged.

Resolution

1) Perform a backup of Cloud Director as outlined here.

2) To rebuild the rpm database run the following command on the impacted cell.

rpm --rebuilddb

3) Restart the snmp service

service snmpd restart

4) Validate the snmp configuration.

vicfg-snmp -s

5)  Validate the snmp is listening on port 161.

ss -tuln | grep 161