EEM Installer Freezing After Clicking Done
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EEM Installer Freezing After Clicking Done

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Article ID: 382377

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Updated On:

Products

CA Service Desk Manager CA Process Automation Base CA Service Catalog

Issue/Introduction

When trying to install EEM, the installer completes and the final step is to click Done

When the user clicks the done button, the installer freezes and never automatically closes. 

Checking Program Files\CA\SC\EmbeddedEntitlementsManager\eiam-install.log and we find the following error:

04 Nov 2024 11:04:14 INFO   - =========================== Uninstall CAPKI 4x ===========================
04 Nov 2024 11:04:14 INFO   - 
04 Nov 2024 11:04:14 INFO  UninstallCAPKIAction4x - CAPKI Platform: WINDOWS
04 Nov 2024 11:04:14 INFO  UninstallCAPKIAction4x - CAPKI uninstall directory is \Windows\amd64\64
04 Nov 2024 11:04:14 FATAL UninstallCAPKIAction4x - Exception occurred during CAPKI 4x uninstall
java.io.IOException: Cannot run program "cmd.exe" (in directory "\Windows\amd64\64"): CreateProcess error=267, The directory name is invalid

The rest of eiam-install.log doesn't contain any additional errors

Environment

EEM 12.6.x

Cause

A process in the environment is preventing the installer from completing as expected. 

We suggest using a software like procmon to look into this.

Process Monitor

Look for processes that are consuming a lot of memory and have a sysadmin verify the source of the process.

Resolution

The error in eiam-install.log is observed in successful installations of EEM 12.6.x so we believe this is not a factor in the reported issue.

After observing the issue, the end user verified functionality in EEM and no issues were found.

If you do run into further EEM related issues after noticing the installer freezing on the last screen, please open a case with Support for investigation.