Action macro is unable to close an SDM ticket
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Action macro is unable to close an SDM ticket

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Article ID: 382323

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

After an SDM Event is triggered, the action macro configured on True runs successfully. However, it can't close the SDM ticket as expected.

The following error appears in the SDM logs:

animator_nxd            5244 SEVERE_ERROR bpmessage.c            779  BPMessage::operator[0]: index out-of-bounds   max = -1
animator_nxd            5244 SIGNIFICANT  bpmessage.c            783  BPMessage[ 738787328.7480.440 ] [User superuser]
animator_nxd            5244 SIGNIFICANT  bpmessage.c            783  {
animator_nxd            5244 SIGNIFICANT  bpmessage.c            783    method = evaluated_condition
animator_nxd            5244 SIGNIFICANT  bpmessage.c            783  }
animator_nxd            5244 SEVERE_ERROR bpobject.c            4998  Attempt to cast type NIL BPData to long

and

ERROR  get_roles failed; cannnot find session with id 0 and userid superuser

 

Environment

SDM 17.x

Cause

Custom spell code located in site/mods folder causing the issue to occur

Resolution

Disable or Modify the custom spell code to allow SDM to run the action macro and close the case.