NTP remains Offline after ensuring NTP Settings are correct in Cloud Director Availability
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NTP remains Offline after ensuring NTP Settings are correct in Cloud Director Availability

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Article ID: 382207

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • In the System Health, there are NTP Errors for some of the Cloud Director Availability (VCDA) components.
  • The VCDA Manager shows as Offline for its NTP Health Status.
  • One of more Replications shows as Offline for its NTP Health Status.
  • Running timedatectl between components
    • Shows a time drift even when the same source is selected.
    • Shows "System clock synchronized: no" even when the same source is selected.
  • Running "journalctl --unit=systemd-timesyncd.service" shows the error "Server has too large root distance".

Environment

VMware Cloud Director Availability 4.6.1

Cause

This can occur if the component is unable to perform the initial sync with the NTP Server.

Resolution

  1. Increase the maximum amount of time allowed for packets to reach the NTP Server:
    • vi /etc/systemd/timesyncd.conf
    • Uncomment RootDistanceMaxSec and set to 30.
    • systemctl restart systemd-timesyncd.service
  1. Review the timedatectl output.
    1. The value System clock synchronized should now say yes.
    2. It should align with the other components which are synched with the server.
  1. Review the System Health in the Manager UI and in the Component UI.
    1. The error messages for NTP should no longer appear.