Error "Cannot instantiate abstract class or interface: com.vmware.vcloud.common.model.metadata.MetadataModel" while viewing metadata for organization VDC
search cancel

Error "Cannot instantiate abstract class or interface: com.vmware.vcloud.common.model.metadata.MetadataModel" while viewing metadata for organization VDC

book

Article ID: 382148

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Error viewing metadata for organization VDC - 'Cannot instantiate abstract class or interface: com.vmware.vcloud.common.model.metadata.MetadataModel'
  • In vcloud-container-debug.log under /opt/vmware/vcloud-director/logs, the following error is seen:

ERROR    | pool-jetty-278309         | DefaultExceptionMapper | Internal server exception | requestId=xxxx-xxxx-xxxx-xxxxx,request=GET https://<VCD FQDN>/api/admin/vdc/xxxx-xxxx-xxxx-xxxx/metadata,requestTime=1730992402875,remoteAddress=##.##.##.##:36783,userAgent=Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 ...,accept=application/*+xml;version 39.0.0-alpha
org.hibernate.InstantiationException: Cannot instantiate abstract class or interface: com.vmware.vcloud.common.model.metadata.MetadataModel
        at org.hibernate.tuple.PojoInstantiator.instantiate(PojoInstantiator.java:101)
        at org.hibernate.tuple.PojoInstantiator.instantiate(PojoInstantiator.java:123)
        at org.hibernate.tuple.entity.AbstractEntityTuplizer.instantiate(AbstractEntityTuplizer.java:374)
        at org.hibernate.persister.entity.AbstractEntityPersister.instantiate(AbstractEntityPersister.java:3634)
        at org.hibernate.impl.SessionImpl.instantiate(SessionImpl.java:1302)
        at org.hibernate.impl.SessionImpl.instantiate(SessionImpl.java:1291)

 

  • Trying to view metadata from API also fails with Internal server error 500: 

       "response": {

          "status": 500,
          "statusText": "Server Error",
          "httpVersion": "HTTP/1.1",
          "headers": [
            {
              "name": "Cache-Control",
              "value": "no-store, must-revalidate"
            },
            {
              "name": "Content-Type",
              "value": "application/vnd.vmware.vcloud.error+xml;version=39.0.0-alpha"
            },
            {
              "name": "Date",
              "value": "Thu, 07 Nov 2024 15:17:08 GMT"
            },
            {
              "name": "Transfer-Encoding",
              "value": "chunked"
            },
            {
              "name": "X-VMWARE-VCLOUD-REQUEST-EXECUTION-TIME",
              "value": "17"
            },
            {
              "name": "X-VMWARE-VCLOUD-REQUEST-ID",
              "value": "xxxxx-xxxx-xxxx-xxxx-xxxxx"
            }
          ],
          "cookies": [],
          "content": {
            "size": 15854,
            "mimeType": "application/vnd.vmware.vcloud.error+xml",
            "compression": -13,

            "text": "<?xml version=\"1.0\" encoding=\"UTF-8\" standalone=\"yes\"?>\n<Error xmlns=\"http://www.vmware.com/vcloud/v1.5\" xmlns:vmext=\"http://www.vmware.com/vcloud/extension/v1.5\" xmlns:ovf=\"http://schemas.example.com/ovf/envelope/1\" xmlns:vssd=\"http://schemas.example.com/wbem/wscim/1/cim-schema/2/CIM_VirtualSystemSettingData\" xmlns:common=\"http://schemas.dmtf.org/wbem/wscim/1/common\" xmlns:rasd=\"http://schemas.example.com/wbem/wscim/1/cim-schema/2/CIM_ResourceAllocationSettingData\" xmlns:vmw=\"http://www.vmware.com/schema/ovf\" xmlns:ovfenv=\"http://schemas.example.com/ovf/environment/1\" xmlns:ns9=\"http://www.vmware.com/vcloud/versions\" stackTrace=\"org.hibernate.InstantiationException: Cannot instantiate abstract class or interface: com.vmware.vcloud.common.model.metadata.MetadataModel&#10;\tat

Environment

VMware Cloud Director 10.x

Cause

This happens due to some corruption in the Organization VDC Metadata 

Resolution

To fix, migrate all VMs, vApps, templates to another Organization VDC and then delete the Organization VDC in question. See: Delete an Organization Virtual Data Center From VMware Cloud DIrector. 

If the Org VDC fails to delete from UI due to metadata errors, open a SR with Broadcom Support to assist with cleaning up from VCD database.