HCX Appliance upgrade fails with error: the operation is not supported on the object
search cancel

HCX Appliance upgrade fails with error: the operation is not supported on the object

book

Article ID: 382027

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

When attempting to upgrade HCX Service mesh appliances such as the Interconnect(IX) and Network Extension (NE), you see the following error in the Tasks UI:

Deploy and Configuration of Interconnect Appliances Failed. Interconnect Service Workflow DeployAppliance failed. Error: Interconnect Service Workflow OvfUpload failed. Error: Unable to get lease in ready state for vCenter https://<Center FQDN>. Cause: the operation is not supported on the object

Site pairing is Up.

HCX appliance tunnels and Up.

vCenter is reachable on the network. You can test this via curl from the HCX manager admin shell: curl -k https://vCenterFQDN

No issues with Storage managed by vCenter.

Similar messages are seen in the HCX manager app log (Path: common/logs/admin/app.log):

DeployAppliance Running in state: CHECK_UPLOAD_OVF for appliance : <ApplianceName>-Redeploying
2024-10-28 18:30:52.538 UTC [InterconnectService_SvcThread-19656, IX:#####-#####-#####-#####-#####, J:#####, , TxId: #####-#####-#####-#####] ERROR c.v.v.h.s.i.DeployAppliance- OvfUpload failed, errorCode:null. stacktrace:null, errorMessage:Unable to get lease in ready state for vCenter https://vCenter FQDN Cause: The operation is not supported on the object.

 Using the transaction ID (TxId) from the HCX error. Check the vCenter logs.

From the vCenter vpxd logs (Path: var/log/vmware/vpxd/vpxd-####.log), the following messages are seen: 

2024-10-28T12:30:51.573-06:00 error vpxd[08564] [Originator@6876 sub=VAppUtil opID=#####-#####-#####-#####-d9-01-01-01] [VpxdVAppUtil] Cannot create a vm inside a resource pool with no folder.

 

Environment

HCX 4.x

Cause

Changes were made to the Compute Profile components that need to be synced with the HCX Service Mesh.

Resolution

Resync the Service Mesh.

Log in to the HCX Manager at the source site: <https://hcxmgr-ip-or-fqdn>

Go to Interconnect > Service Mesh.

Click Resync.

A scan will be performed to check for changes.

Once the scan is complete, the changes to the Compute Profile components will be listed.

To implement the resync, in the popup window, click Resync.

Once the Resync is completed, you may run another resync scan to ensure no other changes are pending.

Retry the appliance upgrade. The upgrade will proceed. There will be tasks in vCenter showing successful OVF deployment.

Additional Information