Object Name: [No Data Available] for 90% of checks for Oracle Evaluation details
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Object Name: [No Data Available] for 90% of checks for Oracle Evaluation details

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Article ID: 382005

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Updated On:

Products

Control Compliance Suite Standards Database

Issue/Introduction

After running a data collection then evaluation job or CER job, the evaluation details show [No Data Available] for the majority of the checks.

No errors are showing up in the console, data collection looks like it was successful as was the evaluation.

Cause

After installing the ODP.NET client there is a manual step to copy over a DLL from the OPD.NET install over to the DPS folder that was missed.

Resolution

The Oracle.DataAccess.dll is required for oracle data collection. Please copy this odp.net client dll to \Symantec\CCS\Reporting and Analytics\DPS on the CCS Manager with the data collection role.

Steps:
1. Copy the file Oracle.DataAccess.dll to the CCS Manager’s install directory at "…\Symantec\CCS\Reporting and Analytics\DPS".
2. Restart the Symantec CCS Manager Service.

Note: The typical path for "Oracle.DataAccess.dll" is "...\client\administrator\product\19.0.0\client_1\odp.net\bin\4".

This step is mentioned in the following document for oracle data collection.
Installing Oracle Database 19c Client (32-bit) for the data collection on Oracle assets (2022-3)