Error NG0701 When Accessing Malware Prevention UI in Trial License Environment
search cancel

Error NG0701 When Accessing Malware Prevention UI in Trial License Environment

book

Article ID: 381988

calendar_today

Updated On:

Products

VMware vDefend Firewall with Advanced Threat Prevention VMware vDefend Firewall

Issue/Introduction

When a customer accesses the Malware Prevention tab in the Security section of the UI, they encounter the following error message:


Error: NG0701
    at Ev (https://xx.xx.xx.xx/napp/antimalware-ui/main.18561250eaeca8e0.js:1:1492969)
    at Fe (https://xx.xx.xx.xx/napp/antimalware-ui/main.18561250eaeca8e0.js:1:1368414)
    at n.setupTicksFormat
    (https://xx.xx.xx.xx/napp/antimalware-ui/projects_antimalware-ui_src_app_features_day2_day2_module_ts.de14c34ee44aea53.js:1:102922)
    at n.setupAxis
    (https://xx.xx.xx.xx/napp/antimalware-ui/projects_antimalware-ui_src_app_features_day2_day2_module_ts.de14c34ee44aea53.js:1:102446)
    at n.setupAxis
    (https://xx.xx.xx.xx/napp/antimalware-ui/projects_antimalware-ui_src_app_features_day2_day2_module_ts.de14c34ee44aea53.js:1:105846)
    at set scale
    (https://xx.xx.xx.xx/napp/antimalware-ui/projects_antimalware-ui_src_app_features_day2_day2_module_ts.de14c34ee44aea53.js:1:102302)
    at n.updateScale
    (https://xx.xx.xx.xx/napp/antimalware-ui/projects_antimalware-ui_src_app_features_day2_day2_module_ts.de14c34ee44aea53.js:1:105701)
    at Object.next
    (https://xx.xx.xx.xx/napp/antimalware-ui/projects_antimalware-ui_src_app_features_day2_day2_module_ts.de14c34ee44aea53.js:1:127322)
    at oe.next (https://xx.xx.xx.xx/napp/antimalware-ui/main.18561250eaeca8e0.js:1:675513)
    at le._next
    (https://xx.xx.xx.xx/napp/antimalware-ui/main.18561250eaeca8e0.js:1:675188)


The error occurs when the customer, using a trial license for MPS and NDR, clicks on the Malware Prevention tab. 

Environment

NAPP 4.2 and earlier
NSX 4.2.1 and earlier
Browser/Platform: Any

Cause

The error NG0701 is caused by a conflict related to unsupported locale settings in the UI. This issue has been found in multiple places. When an unsupported locale setting is used, the UI fails to load properly, leading to an error. The currently supported locales are en-US, de-DE, es-ES, fr-FR, ja-JP, ko-KR, zh-CN, zh-TW, and it-IT. All other locales are not fully supported.

In this case, the customer locale seems to be set to da-DK, causing the Malware Prevention UI (and other sections like the Upgrade UI, NSX Intelligence UI, etc.) to fail to display properly. This crash could occur in various places; in this instance, it caused a failure in the DatePipe, a native Angular library, resulting in an NG0701 error. This issue is more noticeable in environments using trial licenses, but it can also occur in other situations if the locale is set improperly.

Resolution

The fix will be merged in a future release. 

 

Workaround :


The workaround is to change the locale to any supported locale, such as en_US.

Follow these steps to change the locale:

Navigate to the system locale settings.
Set the locale to en_US or another supported locale.
Reload the UI to ensure the changes take effect and confirm that the issue is resolved.

 

Additional Information

Change Locale in Google Chrome:


Open Chrome and go to Settings (three dots in the top-right corner).
Scroll down to Languages under Advanced.
Click Language, then Add languages to select English (United States) or another supported locale.
Set your preferred language and restart Chrome.


Change Locale in Mozilla Firefox:

Open Firefox and go to Settings (three horizontal lines in the top-right corner).
Under General, scroll to Language and Appearance.
Click Choose under Language, select English (United States) or another supported locale.
Restart Firefox.

Change Locale in Safari (macOS):

Go to System Preferences > Language & Region.
Add English (United States) or another supported language and drag it to the top.
Restart Safari for changes to take effect.