After CABI Upgrade superuser cannot log in in cabijs
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After CABI Upgrade superuser cannot log in in cabijs

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Article ID: 381985

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

I have upgraded CABI successfully, however, the superuser cannot log in. It simply returns to the log in screen. No error message. 

Environment

  • DX UIM 20.4.* / 23.4.*3
  • cabi 8.* / 23.4*
  • Database MSSQL Server

Cause

This issue can happen if the superuser is disabled

Resolution

1. Try loggin in with the superuser one more time. If it still fails: 

2. Run the following query on your UIM DB: 

select * from jiuser where username = 'superuser'

3. and verify that the enabled field is equal to 1. If it's equal to 0 the superuser won't be able to log in. 

4. Run the following query to enable the superuser. 

UPDATE jiuser set enabled=1 where username ='superuser' 

 

 

Additional Information