NSX-T cloud account data collections fails when it's is on federated environment
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NSX-T cloud account data collections fails when it's is on federated environment

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Article ID: 381963

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

When NSX-T is on federated environment the data collection on Aria Automation fails with below error:

NotFound (com.vmware.vapi.std.errors.not_found) => {
messages = [],
data = struct => {error_message=The requested URI: /api/v1/orgs/default/projects could not be found.,
error_code=258, module_name=common-services},
errorType = NOT_FOUND
}

Environment

VMware Aria Automation 8.17.x, VMware Aria Automation 8.18.1
VMware NSX 3.3.2 and later

Cause

The issue can occur using NSX-T Federation with a NSX-T Global Manager

The issue can also occur for environments configured for NSX multi tenancy:

Integration with NSX Federation is not supported in VMware Aria Automation for NSX releases 3.2.2 and later
Aria Automation will not collect multi tenancy resources on the NSX federated environment.

Source : https://techdocs.broadcom.com/us/en/vmware-cis/nsx/vmware-nsx/4-2/administration-guide/nsx-multi-tenancy/nsx-projects.html

Resolution

The issue is resolved with version Aria Automation 8.18.1 Patch 2

  • Integration with NSX Federation is not supported in VMware Aria Automation for NSX releases 3.2.2 and later

    When using NSX-T Federation, NSX-T Global Manager enumeration fails for NSX version 3.2.2 and later when used in VMware Aria Automation 8.17 and 8.18.

    The failure causes the following error message to appear: 

    The requested URI: /api/v1/transport-nodes could not be found

    This issue does not impact non-federated environments. To resolve this issue, users must either use NSX version 3.1.x or upgrade to VMware Aria Automation 8.18.1.

 

For environments with NSX multi tenancy:

To workaround this, we should manually disable the NSX multi tenancy information from Aria Automation. This process involves modifying the internal configuration and direct changes of the Database of Aria Automation.

Please open a ticket with Broadcom support