When trying to add user/ sync groups from added directory in VMware identity Manager flags Sync alerts
Failed to sync users in VMware Identity Manager
Sync alerts are similar to: The example screenshot above shows a alerts flagging a few generic binding attributes missing such as firstname, lastname, email, however, there could be many others as per configuration.
Example of an email attribute error during a directory sync operation:
Environment
VMware Identity Manager 3.x.
Cause
It is essential for the users to have the values for the attributes, marked as required in VMware Identity Manager, for them to be synced.
Resolution
Validate that the user has values in AD for the attributes marked as required for them to be synced successfully.
Re-run the directory sync post updating the attributes in AD.
Additional Information
Note: In case of multi-tenant vIDM/ Aria Automation set up, ensure the directory sync is validated on the respective tenant vIDM.