vSAN license not able to be applied due to incorrect storage size
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vSAN license not able to be applied due to incorrect storage size

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Article ID: 381817

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Updated On:

Products

VMware vSAN 8.x

Issue/Introduction


Customer purchased new vSAN license for the capacity of the vSAN Cluster but when they tried  to apply the license it claims they don't have enough vSAN capacity licensed.

Environment

vSAN 8.x

Cause

One of the disks on a vSAN host failed with PDL and was unplugged from the host, since it was not removed properly it was still present in the ConfigStore config and counting towards Total vSAN Capacity which was more than the license key was authorized for.


Resolution

Workaround:
Please follow steps as below to resolve the issue:
1. please confirm the current configured disks in the ConfigStore config by running this command on the ESXi host "configstorecli config current get -c vsan -g system -k host_config".
2. Compare disks list from the output of the step 1 with esxcli vsan storage list | grep ^naa and identify the failed disks also note failed disk UUID from the configstorecli output.
3. You can also confirm the failed disk naa id from vmkwarning logs
4. Once identified use following command to remove the uuid of the failed disk

esxcli vsan storage remove -u <UUID of the failed disk>

5. After this step, please run configstorecli command as below again to verify the disk entry is indeed removed.

"configstorecli config current get -c vsan -g system -k host_config"

After this, the total license capacity usage should not include the PDL disk and assigning a license that covers the capacity can be allowed.