vSAN license not able to be applied due to incorrect storage size
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vSAN license not able to be applied due to incorrect storage size

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Article ID: 381817

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Updated On:

Products

VMware vSAN 8.x

Issue/Introduction

Symptoms:

  • Customer purchased new vSAN license for the capacity of the vSAN Cluster but when they tried  to apply the license it claims they don't have enough vSAN capacity licensed.

  • Existing environments with license already applied may report the alert "License inventory monitoring. License inventory is not compliant. Licenses are overused".

  • Following error could also be observed where 'Usage' space shows up as higher than 'Capacity' under Licenses tab.

    • License inventory is not compliant. Licenses are overused

      Event Type Deception
      vCenter Server does not strictly enforce license usage. Instead. it checks for Incense overuse periodically. If vCenter Server detects overuse. it logs this event and triggers an alarm.

      Possible Causes
      Overuse of licenses Action: Check the license reports through the vSphere Client and reduce the number of entities using the License key or add a new license key with a greater capacity.

Environment

VMware vSAN 8.x

Cause

One of the disks on a vSAN host failed with PDL and was unplugged from the host, since it was not removed properly it was still present in the ConfigStore config and counting towards Total vSAN Capacity which was more than the license key was authorized for.


Resolution

Workaround:

Follow steps as below to resolve the issue:

  1. Confirm the current configured disks in the ConfigStore config by running this command in the SSH of ESXi host: configstorecli config current get -c vsan -g system -k host_config

  2. Compare disks list from the output of the step 1 with esxcli vsan storage list for the devices where "Is Capacity Tier: true" and identify the failed disks also note failed disk UUID from the configstorecli output. The output of this command shows the currently in-use disks.

  3. Once identified use following command to remove the uuid of the failed disk: esxcli vsan storage remove -u <UUID of the failed disk>

  4. After this step, run configstorecli command again to verify the disk entry is removed: configstorecli config current get -c vsan -g system -k host_config

Note: In case the entry remains in configstore, follow the steps in KB Unable to apply vSAN OSA cluster license.


After this, the total license capacity usage should not include the stale disk's usage and assigning a license that covers the capacity will work.