Unable to add hard disk of the VMware Aria Operations for Logs Virtual Appliance more than 2 TB
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Unable to add hard disk of the VMware Aria Operations for Logs Virtual Appliance more than 2 TB

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Article ID: 381809

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

After attempting to expand the disk space for VMware Aria Operations for Logs (VRLI) clusters more than 2 TB, the nodes did not reflect the expected disk space change. 

 

Environment

VMware Aria Operations for Logs 8.x

Cause

The issue is caused by a known limitation within VMware Aria Operations for Logs (VRLI).

VRLI supports virtual hard disks of up to 2 TB. If a user attempts to add a disk greater than 2 TB, the platform does not support this configuration and will not expand the disk space accordingly.

Therefore, attempting to allocate a single disk larger than 2 TB results in the system not recognizing the added capacity.

Resolution

To resolve the issue and successfully expand the storage capacity for the VRLI virtual appliance, the recommended approach is to add multiple virtual hard disks rather than attempting to expand a single disk beyond the 2 TB limit.

Steps to resolve:

  1. Power off the VRLI appliance to make changes to the disk configuration.
  2. Add additional virtual disks up to the desired storage capacity. Each disk should be 2 TB or less.
  3. Once the new disks are added, reconfigure the disk settings within VMware Aria Operations for Logs to ensure that the system recognizes the new disks and storage.
  4. Power on the VRLI appliance and verify that the new disks are detected and that the storage expansion is reflected on the nodes.

Additional Information

 

  • Ensure that the virtual disks are properly formatted and mounted within the operating system for the expansion to take effect.
  • Always ensure the total disk space meets your organization's requirements while staying within the supported limits for each disk.