VMware Aria ITSM Plug-in for ServiceNow not populating dropdowns after upgrade to 8.18.x
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VMware Aria ITSM Plug-in for ServiceNow not populating dropdowns after upgrade to 8.18.x

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Article ID: 381803

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • After upgrading ServiceNow instance to Xanadu, Aria Automation to 8.18.x, and Aria Automation ITSM Plug-in for ServiceNow to 8.18.x, dropdowns are no longer populating with the dynamic data.
  • This happens when you open a Catalog Request that includes fields with dropdowns.  So simply trying to request a catalog item that contains multiple-choice dropdown fields is all that is required to repro this issue.
  • Errors are seen in the ServiceNow logs:


  • It has been observed that external API calls for drop down fields are returning a 403 Forbidden HTTP status code when the project parameter in the endpoint is empty.
  • In the native UI, the onChange client script "u_version_single" is triggered after successfully populating the project field, which prevents the issue of receiving a 403 status code.
  • In the Service Portal, this OnChange client script is triggered before the project field is populated. As a result, external API calls are made without the project ID, leading to the 403 Forbidden status.
  • Although the "On Load to get versions and Project" client script logic ensures that the version field is populated after the project value is set ,but the Service Portal is behaving differently, with the sequence of field population reversed.
  • This behavior appears to be a platform-specific issue with the Service Portal.
    • Note: Having multiple version cat item resolved the issue.

Environment

Aria Automation 8.17
Aria Automation 8.18.x

Cause

  • This behavior is platform-specific issue with the Service Portal.
  • In the Service Portal, this OnChange client script is triggered before the project field is populated. As a result, external API calls are made without the project ID, leading to the 403 Forbidden status

Resolution

The issue is resolved with Aria Automation ITSM plugin version 8.18.1

Workaround: