Mix of file versions in Agent 14.5 CU7 with DSM Explorer
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Mix of file versions in Agent 14.5 CU7 with DSM Explorer

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Article ID: 381777

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Updated On:

Products

CA Client Automation CA Client Automation - IT Client Manager

Issue/Introduction

On an Agent 14.5 CU7 with a remote DSM Explorer installed, there is a mix of file versions. Some files are correctly in CU7 version but some files from CU7 patch are not installed.

Example :
File gui_rcSAView.dll is in version CU7 (14.5.7.632)
But file gui_sd.dll (which is part of CU7) is still in version 14.5.0.153 :


Environment

Client Automation 14.5 CU7

Cause

All files in old version are files from DSM Explorer. This problem occurs with following installation scenario :

  1. An Agent is in version 14.5. There is no DSM Explorer installed. The patch CU7 is installed. But files for DSM Explorer are not installed as there are no DSM Explorer installed.

  2. Later DSM Explorer 14.5 is installed on this Agent. But files for DSM Explorer are in version 14.5.

Resolution

Apply again the patch CU7 on the Agent.

To install again the patch CU7 following article could be used :

Exit code 112 error when trying to install again a CU patch

Additional Information

Here are the different valid scenario to have an Agent 14.5 with DSM Explorer all in CU7 :
 
  • Agent is in version 14.5 without DSM Explorer

    - Install "DSM Explorer 14.5.0.153"
    - Install CU7 patch "CA DSM Agent + Explorer +  Scalability Server 14.5 CU7 (Win32 only) 14.5.7.632"


  • Agent is in version 14.5 with DSM Explorer

    - Install CU7 patch "CA DSM Agent + Explorer +  Scalability Server 14.5 CU7 (Win32 only) 14.5.7.632"


  • Agent is in version 14.5 CU7 without DSM Explorer

    - Install "DSM Explorer 14.5.0.153"
    - Reinstall CU7 patch "CA DSM Agent + Explorer +  Scalability Server 14.5 CU7 (Win32 only) 14.5.7.632" using method in article 
    Exit code 112 error when trying to install again a CU patch