"Resume attempted maximum number of times. Cannot resume patching anymore" error while performing vCenter Patching
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Article ID: 381762
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Updated On:
Products
VMware vCenter Server
Issue/Introduction
Several attempts to continue the patch have failed, you see similar message to below:

Environment
vCenter Server 7.0
vCenter Server 8.0
Cause
Too many failed attempts have been made to continue the patch, and no further attempts are allowed.
Resolution
To work around this issue, follow the steps below:
-
Log in to your vCenter Appliance shell via SSH.
- Run the following command:
software-packages unstage
- Stop the appliance management service:
service-control --stop applmgmt
- Remove the update files:
rm -rf /storage/core/software-update/updates/*
rm -rf /storage/core/software-update/stage/*
rm -rf /storage/db/patching.db
- Move the staged configuration files:
mv /storage/core/software-packages/staged-configuration.json /storage/core
mv /etc/applmgmt/appliance/software_update_state.conf /storage/core
- Restart the appliance management service:
service-control --start applmgmt
- Reboot the vCenter server:
Additional Information
To help understand why the patch is failing, please follow below:
- Please collect VC logs and ensure these are saved Collecting diagnostic information for VMware vCenter Server 7.x and 8.x
- Please proceed to now restore VCSA to snapshot or file-based backup taken prior to the patch attempts
- Open a case with our support team and upload the VCSA logs to be reviewed
- If no Backups are available, a reinstall of the vCenter environment is required
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