CABI Adhoc report error
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CABI Adhoc report error

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Article ID: 381750

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

While trying to run the cabi adhoc report facing below error:

Environment

Release: Any DX UIM

Component: CABI

Cause

200,000 rows are the Jaspersoft Server Setting default.

Resolution

Increase the value for Ad Hoc Dataset Row Limit within the Jaspersoft Admin Page:
 

There are two ways to change this value: temporary and permanent.

Temporary Solution (reset on server restart)

NB: on server restart the value would revert to default.

  • Login as Superuser.
  • Go to Manage -> Ad Hoc Settings
  • Set "Ad Hoc Dataset Row Limit" to desired value.

Permanent Solution

You can permanently increase this limit by editing applicationContext-semanticLayer.xml file under WEB-INF directory and change the settings to a larger limit to accommodate your needs:

  • go to the bottom of the file and locate the bean property

 

  • change the limit value for the setting bellow (default setting is 200000):

 

  • save the change, restart your server and run the report again.

Additional Information