wildfly timeout errors when starting PAM
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wildfly timeout errors when starting PAM

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Article ID: 381680

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Updated On:

Products

CA Process Automation Base

Issue/Introduction

The following error appears in PAM/logs/server.log:

ERROR [org.jboss.as.controller.management-operation] (Controller Boot Thread) WFLYCTL0348: Timeout after [600] seconds waiting for service container stability. Operation will roll back. Step that first updated the service container was 'add' at address '[
    ("core-service" => "management"),
    ("management-interface" => "http-interface")
]'

Environment

PAM 4.4 GA and later

Cause

WildFly Default timeout for the deployment is 600 sec which may not be sufficient for the system resources. Timeout needs to be increased.

Resolution

1. Look for "urn:jboss:domain:deployment-scanner" in PAM\wildfly\standalone\configuration\standalone-full-ha.xml and modify as follows. 

<subsystem xmlns="urn:jboss:domain:deployment-scanner:2.0">
           <deployment-scanner path="deployments" relative-to="jboss.server.base.dir" scan-interval="5000" runtime-failure-causes-rollback="${jboss.deployment.scanner.rollback.on.failure:false}" deployment-timeout="1200000"/>
</subsystem>

2. Save Changes

3. Start PAM Services