Re-Docking Workspace and Output Views inside the Administrator Tool

book

Article ID: 38161

calendar_today

Updated On:

Products

CA Harvest Software Change Manager - OpenMake Meister

Issue/Introduction

Introduction: 

The CA Harvest SCM Administrator Tool desktop window is configurable.  You can dock and undock and hide and “reveal” the sections within it and arrange the display according to your preference.  If, however the display gets changed by mistake or you want to revert back to the window’s original configuration, sometimes this is a bit more challenging.  This document explains how to “re-dock” sections within the window that have become “undocked”.

Background:  

The Project Workspace and Output windows inside the SCM Administrator Tool can be configured in a variety of different ways.  You can “detach” them from the main window by double-clicking in the header bar for the window:

<Please see attached file for image>

Admin_Redock_001.jpg

When you double click, that window becomes a detached, free-floating window that can be moved around as needed:

 

<Please see attached file for image>

Admin_Redock_002.jpg

Each of these windows has a property called “Docking View” that determines whether the window should be “reattached” to the main window if it is dragged close to the upper or left edge of the main window.  You can check the “Docking View” property by right-clicking in the white-space of the window:

<Please see attached file for image>

Admin_Redock_003.jpg

If this property does not have a check-mark beside it, you can move the window anywhere and it will never reattach to the main window. 

Environment:  

CA Harvest SCM Client, All versions on the Windows platform

Instructions: 

If you want to restore the original configuration of the Administrator tool, first make sure that both the Project Workspace window and the Output Window are visible.  If they are not, go to the View menu and select them:

<Please see attached file for image>

Admin_Redock_004.jpg

 

Next, right click in the white-space of each window and make sure the “Docking View” property is selected:

<Please see attached file for image>

Admin_Redock_005.jpg

Click in the header bar of the Output Window and drag left.  The window itself doesn’t move but a “shadow” of the window moves with your mouse so that you can see where it’s going.  Drag left until the left edge of the “shadow” is beyond the left edge of the main window:

<Please see attached file for image>

Admin_Redock_006_1.jpg 

When you let go of the mouse button, the Output Window is now positioned to fill the lower half of the main window:

<Please see attached file for image>

Admin_Redock_007.jpg

Click the header bar of the Project Workspace window and drag to the upper-left corner of the main window:

<Please see attached file for image>

Admin_Redock_008.jpg

Once again, the window itself won’t move but its “shadow” will show you where the window will wind up.  When you let go of the mouse button, the Project Workspace window is docked in its proper place:

<Please see attached file for image>

Admin_Redock_009.jpg

Remembering Your Preferred Configuration

There is an option you can “un-set” that will allow you to restore your preferred configuration when starting up.  If you select Tools and Options, the Options window displays.  One of the options you can configure is “Save window state”:

<Please see attached file for image>

Admin_Redock_010.jpg

If this option is selected, the positions of the windows within the main window will be “remembered” for the next time you start up.  If it’s not selected, the Administrator tool will revert back to the last “saved” locations of the windows and will display that at startup.  So, to make your restoration permanent:

1.       Configure your Project Workspace window and Output Window the way you prefer to see them.

2.       Check Tools->Options to make sure “Save window state” is selected.

3.       Select File->Exit to close the Administrator tool.

4.       Start the Administrator tool again. 

5.       Go back to Tools->Options and un-check the “Save window state” option. 

Once this is done, if your window configuration goes awry again, all you have to do is close and reopen Administrator to restore your window configuration.

 

 

Environment

Release: SCMNCR99000-12.5-Harvest-Software Change Manager-Named User-Competitive Replacem
Component:

Attachments

1558723651360000038161_sktwi1f5rjvs16wxo.jpeg get_app
1558723649364000038161_sktwi1f5rjvs16wxn.jpeg get_app
1558723647581000038161_sktwi1f5rjvs16wxm.jpeg get_app
1558723645932000038161_sktwi1f5rjvs16wxl.jpeg get_app
1558723644105000038161_sktwi1f5rjvs16wxk.jpeg get_app
1558723641716000038161_sktwi1f5rjvs16wxj.jpeg get_app
1558723640114000038161_sktwi1f5rjvs16wxi.jpeg get_app
1558723638272000038161_sktwi1f5rjvs16wxh.jpeg get_app
1558723636292000038161_sktwi1f5rjvs16wxg.jpeg get_app
1558723634340000038161_sktwi1f5rjvs16wxf.jpeg get_app