Dashboard Portlets Fail To Load With Error: Refused To Connect
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Dashboard Portlets Fail To Load With Error: Refused To Connect

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Article ID: 381599

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Updated On:

Products

Carbon Black App Control

Issue/Introduction

When accessing the App Control Console Dashboard the Portlets (or widgets) fail to load showing the error: refused to connect

Environment

  • App Control Console: All Supported Versions
  • Microsoft IIS: All Supported Versions

Cause

A Content Security Policy has been applied which restricts Frame Ancestors.

Resolution

If the Content Security Policy is not required, remove it following these steps:

  1. Log in to the application server as the Carbon Black Service Account.
  2. Launch IIS Manager (Start > Run > inetmgr)
  3. Select the SERVERNAME
  4. In the middle pane > IIS > double click: HTTP Response Headers
  5. Remove the Content-Security-Policy with a Value containing frame-ancestors, example:
    frame-ancestors 'none'
  6. From the left-hand navigation > select the SERVERNAME 
  7. From the right-hand navigation > Actions > Restart
  8. After IIS restarts, log back in to the Console and verify the Portlets are restored.

Additional Information