Dashboard Portlets Fail To Load With Error: Refused To Connect
book
Article ID: 381599
calendar_today
Updated On:
Products
Carbon Black App Control
Issue/Introduction
When accessing the App Control Console Dashboard the Portlets (or widgets) fail to load showing the error: refused to connect
Environment
- App Control Console: All Supported Versions
- Microsoft IIS: All Supported Versions
Cause
A Content Security Policy has been applied which restricts Frame Ancestors.
Resolution
If the Content Security Policy is not required, remove it following these steps:
- Log in to the application server as the Carbon Black Service Account.
- Launch IIS Manager (Start > Run > inetmgr)
- Select the SERVERNAME
- In the middle pane > IIS > double click: HTTP Response Headers
- Remove the Content-Security-Policy with a Value containing frame-ancestors, example:
frame-ancestors 'none'
- From the left-hand navigation > select the SERVERNAME
- From the right-hand navigation > Actions > Restart
- After IIS restarts, log back in to the Console and verify the Portlets are restored.
Feedback
thumb_up
Yes
thumb_down
No