Port conflict in DNS resolution service with Aria Operations for Network Appliances
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Port conflict in DNS resolution service with Aria Operations for Network Appliances

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Article ID: 381553

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Updated On:

Products

VMware Aria Operations for Networks

Issue/Introduction

DNS lookup may timeout or take longer.

When we look at the ports listening to 53 we see it is listening to 2 services DNS and systemdresolved which caused port conflict which may affect DNS resolution.

ubuntu@aria-networks-platform:~$ sudo lsof -i :53
COMMAND    PID            USER   FD   TYPE    DEVICE SIZE/OFF NODE NAME
dnsmasq   1046         dnsmasq    4u  IPv4     11495      0t0  UDP localhost:domain
dnsmasq   1046         dnsmasq    5u  IPv4     11496      0t0  TCP localhost:domain (LISTEN)
systemd-r 9380 systemd-resolve   13u  IPv4     42767      0t0  UDP localhost:domain
systemd-r 9380 systemd-resolve   14u  IPv4     42768      0t0  TCP localhost:domain (LISTEN)
systemd-r 9380 systemd-resolve   17u  IPv4 550915375      0t0  UDP localhost:43240->localhost:domain
systemd-r 9380 systemd-resolve   18u  IPv4 550915376      0t0  UDP localhost:60097->localhost:domain
systemd-r 9380 systemd-resolve   19u  IPv4 550935042      0t0  UDP 192.###.###.###:38057->192.###.###.###:domain
systemd-r 9380 systemd-resolve   20u  IPv4 550935043      0t0  UDP 192.###.###.###:41226->192.###.###.###:domain
ubuntu@aria-networks-platform:~$

>sudo systemctl status systemd-resolved
  systemd-resolved.service - Network Name Resolution
     Loaded: loaded (/lib/systemd/system/systemd-resolved.service; enabled; vendor preset: enabled)
     Active: active (running) since Wed 2024-11-06 09:13:35 UTC; 2 days ago
     ........
  Nov 08 19:10:13 aria-networks-collector systemd-resolved[2506]: Using degraded feature set UDP instead of TCP for DNS server 127.0.0.1.

Environment

Aria Operations for Network Appliances 6.14.0

Cause

With upgrade to Ubuntu 22, systemd-resolved DNS stubListener incapacitates expected use of DNSMasq resolver in system.

Resolution

If you believe you have encountered this issue, please open a support case with Broadcom Support and refer to this KB article. For more information, see Creating and managing Broadcom support cases.