After ungracefully shutdown of SpectroSERVER can't start Archive Manager
search cancel

After ungracefully shutdown of SpectroSERVER can't start Archive Manager

book

Article ID: 38154

calendar_today

Updated On:

Products

CA Spectrum

Issue/Introduction

After an unexpected shutdown of the server where SpectroSERVER is running, the Archive Manager does not start.

The error message in $SPECROOT/SS/DDM/ARCHMGR.OUT is as follow:

Can't find file: 'event' (errno: 2)

Environment

Release:
Component:

Cause

This error message is reporting a problem with the MySQL database files. Specifically, those for the event table.

Resolution

To repair the Archive Manager database:

1. Log into the SpectroSERVER system as the user that owns the Spectrum installation

2. If on Windows, start a bash shell by running "bash -login"

3. cd to the $SPECROOT/SS/DDM directory and run the following command:

./ArchMgr -repair

NOTE: This could take some time depending on the size of the Archive Manager database



4. After completing successfully, start the Archive Manager process as normal

Additional Information

Please reference the "DDM Database Maintenance" section of the documentation for more information.