Unable to access OpenAPI when authenticating with SAML2
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Unable to access OpenAPI when authenticating with SAML2

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Article ID: 38143

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration

Issue/Introduction

Symptoms: 

Receiving SAML2 authentication error or Timeout when accessing OpenAPI at

http://<DA hostname>:8581/odata/api

Environment:  

Applies to Performance Manager 2.4+

Cause: 

The API at http://<DA hostname>:8581/odata/api does not support SAML2 authentication

 

Environment

Release: IMDAGG99000-2.6-Infrastructure Management-Data Aggregator
Component:

Resolution

Resolution/Workaround:

Use the QueryBuilder at http://<DA hostname>:8581/odataquery

In case you see further Problems with your SAML2 setup you can login with a local CAPC user account that does not authenticate with SAML2.

  1. https://CAPCHOST:8382/sso/sign-in.jsp?SsoProductCode=da,
  2. Entered the DAHOST, local username and password

 

  1. You will be logged in and redirected to http://DAHOST:8581/odataquery/index.html