Issue/Problem/Symptoms:
Unable to add/save a new profile for the Salesforce probe v2.00
Error message displayed:
<Please see attached file for image>
Error in salesforce.log:
[attach_socket, salesforce] Config node modified 'idsProbeInfo' of type 'Config'
[attach_socket, salesforce] configDefinitionName :SF_CLOUD_SETTINGS
[attach_socket, salesforce] configDefinitionName :probeSetup
[attach_socket, salesforce] configDefinitionName :SF_PROXY_SETTINGS
[attach_socket, salesforce] cbSetCtdConfiguration failed
[attach_socket, salesforce] java.lang.NullPointerException
at com.nimsoft.nimbus.NimSecurity.encrypt(NimSecurity.java:142)
at com.nimsoft.nimbus.NimSecurity.encryptISO(NimSecurity.java:84)
at com.nimsoft.probe.common.cms.AbstractProbe.getEncryptedPass(AbstractProbe.java:317
Environment:
Salesforce probe v2.00
Cause:
Problem with Salesforce v2.00
Resolution/Workaround:
1. Temporarily Enable the "Enable Proxy" option for the Salesforce probe
Configure Proxy with a valid IP and anything for user credentails
2. After Enable Proxy settings are saved, create/save the Profile
3. Disable the Proxy Enabled option and restart the Salesforce probe.