What is the meaning of the error message "Exception: Key not available for node"
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Article ID: 38128
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Updated On:
Products
DSERIES- SERVERCA Workload Automation DE - System Agent (dSeries)
Issue/Introduction
The tracelog on the DE manager contains an error "Exception: Key not available for node" for an agent.
Cause
The manager is being contacted by the agent but the agent is missing in agent definition in the topology.
Resolution
Either remove the manager definition from the agentparm.txt file or add the agent to the manager in dSeries (DE) Topology.
Option 1: Remove manager definition in agent's agentparm.txt
Login to the host using the IP provided from tracelogs. The Administrator or root privileges may be needed to perform changes to the agentparm.txt.
Navigate to agent install directory
Edit the agentparm.txt file in the install directory.
Locate dSeries server related entries in the agentparm.txt. Example: communication.managerid_n=CENTRAL_MANAGER communication.manageraddress_n=##.##.###.### (The IP/hostname should match the dSeries IP/hostname) communication.managerport_n=7507 communication.monitorobject_n=MY_AGENT/AGENTMON1.0/MAIN
Remove all of the defined parameters for the invalid manager, using the above as example, and save the file. Note: If you have multiple managers defined in agentparm, it is important to ensure that the numbering associated with each manager remains sequential, meaning to not skip numbers. Neglecting to do so, will result in the agent being unable to communicate with additional managers above the skipped number. Example:
You have 3 managers defined in the agentparm.txt.
Each manager definition has the above 4 parameters defined with a _n appended, where n is the number associated with a specific manager.
Your organization decided they no longer needed the second manager.
So, you'll delete all parameter references to the manager having _2 appended to it.
Now, you have to renumber the parameters having _3 appended to it to reflect _2.
Perform a cold start of the agent.
Execute cybAgent -s to Stop the agent service
Rename the database directory beneath the agent (database.mmddyyyy or something similar).
Execute cybAgent -a to Start the agent
Option 2: Add the agent to the manager in Admin -> Topology If the agent needs to be added to the dSeries Topology, then please perform the following steps.
Login in to Desktop Client as ADMIN or user with ADMIN privileges
Navigate to Admin perspective and open Topology tab.
Right click on the Agents section and select New Agent.
Enter the agent information and save it. The agent has now been added to the manager.