sysadmin having difficulty obtaining the rsyslog process ID
search cancel

sysadmin having difficulty obtaining the rsyslog process ID

book

Article ID: 381276

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Post OS upgrade from RHEL7 to RHEL 8, the syslog configuration changed causing the sysadmin to have difficulty obtaining the rsyslog process ID.

Environment

NCM - 10.1.X

Cause

1). Post OS upgrade from RHEL7 to RHEL 8 PID file name changed from /var/run/syslogd.pid to /var/run/rsyslogd.pid

2). However in $VOYENCE_HOME/sysadmin/config/serverConfig.xml syslog PID file is configured as /var/run/syslogd.pid, due to which sysadmin is unable to obtain rsyslog PID in $VOYENCE_HOME/sysadmin/state/serverState.xml file.

Resolution

Edit the file $VOYENCE_HOME/sysadmin/config/serverConfig.xml and set rsyslog PID file as /var/run/rsyslogd.pid

  <MonitoredProcess desiredState="Running" logLevel="Verbose" monitorType="pid" processName="Syslogd">
        <PidFile>/var/run/rsyslogd.pid</PidFile>
        <OnStart>