VMware vSphere Auto Deploy displays error - "Managing depots is temporarily unavailable: Invalid Fault"
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VMware vSphere Auto Deploy displays error - "Managing depots is temporarily unavailable: Invalid Fault"

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Article ID: 381269

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Updated On:

Products

VMware vSphere ESXi 8.0 VMware vSphere ESXi 7.0 VMware vSphere ESX 6.x VMware vCenter Server

Issue/Introduction

  • In the vSphere Client, click Hamburger button on the left and select Auto Deploy.
  • In Auto Deploy, Software Depots and Deploy Rules tabs are not working and getting below errors message.
  • Error in Software Depots tab:

  • Error in Deploy Rules tab:

Environment

VMware vCenter Server Appliance 7.x

vSphere ESXi 7.x

Cause

  • A recent certificate replacement on the vCenter can trigger this behaviour.
  • Imagebuilder plugin in vSphere Client fails to authenticate against the imagebuilder service.

 

/var/log/vmware/rbd/rbd-server.log:

[YYYY-MM-DDTHH:MM:SS] [31297]ERROR:SoapHandler:(vim.fault.InvalidLogin) {
   dynamicType = ,
   dynamicProperty = (vmodl.DynamicProperty) [],
   msg = 'Cannot complete login due to an incorrect user name or password.',
   faultCause = ,
   faultMessage = (vmodl.LocalizableMessage) []

 

 

/var/log/vmware/rbd/rbd-vc-monitor.log

[YYYY-MM-DDTHH:MM:SS] [32474]INFO:rbd_vc_monitor:vc-monitor exiting
[YYYY-MM-DDTHH:MM:SS] [34576]INFO:rbd_vc_monitor:vc-monitor starting for <VC_FQDN>
[YYYY-MM-DDTHH:MM:SS] [34576]INFO:dbsetup:installed DB connection for thread <_MainThread(MainThread, started 139668914661184)>
[YYYY-MM-DDTHH:MM:SS] [34576]INFO:vc_servers:client SSL material -- /etc/vmware-rbd/ssl/waiter.key, /etc/vmware-rbd/ssl/waiter.crt
[YYYY-MM-DDTHH:MM:SS] [34576]ERROR:rbd_vc_monitor:cannot login to VC < VC_FQDN>

Resolution

To fix this issue, re-register the Image builder extension to VC from the mob page:

  1. Open the vCenter MOB extension manager, URL https://VC_FQDN/mob/?moid=ExtensionManager
  2. Login with the SSO administrator account ( Eg: [email protected]).
  3. Click on UnregisterExtension in the Methods table:
  4. In the window that pops up, populate the "VALUE" field with the string com.vmware.imagebuilder and click on Invoke Method.
  5. Open an SSH connection to the vCenter Server and restart the imagebuilder service. Command: service-control --restart vmware-imagebuilder
  6. Login to vSphere Client to confirm if the issue is fixed.