HCX "Error loading Site Pairings Error: Unable to process HCX inventory details" even when logged in as "administrator@vsphere.local"
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HCX "Error loading Site Pairings Error: Unable to process HCX inventory details" even when logged in as "[email protected]"

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Article ID: 381257

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Updated On:

Products

VMware HCX

Issue/Introduction

Users may encounter an issue in VMware HCX where the inventory cannot be loaded from a site pairing, accompanied by the error message:

Error loading Site Pairings:
Error: Unable to process HCX inventory details.

This problem occurs even when logged in with the "[email protected]" or an equivalent admin user account, which typically has sufficient privileges to manage HCX operations.

Cause

There could be several reasons for this error or issue, as the HCX inventory is primarily pulled from vCenter, in addition to its own database, any difficulty in retrieving the inventory, due to factors such as network issues or permission restrictions, etc., could lead to this problem.

Resolution

Below are some of the troubleshooting steps you could perform the narrow down the issue further:

Verify the integrity/stability of the appliance(vCenter, HCX Manager, and fleet appliances) by accessing it via the console, ensuring that it is not in read-only mode or showing any read errors, etc. Here are examples of the appliance console output when they were not functioning as expected.

    • HCX  Manager showing "Read-error on swap-device"



    • HCX Fleet Appliances in "You are in emergency mode", such as the IX appliance, are shown below.



    • Note: The above behavior can also be observed in other appliances, such as vCenter.

Please note that if there are storage-related changes or issues, virtual machines (VMs) that were previously up and running may start exhibiting unexpected behavior. This could occur depending on the extent of the impact from the changes or issues, or if the virtual machines do not receive responses from the storage quickly enough, causing the filesystem to go into read-only mode. In this case, you need to fix the storage issue and then reboot these VMs. Please note that even if all the HCX appliances are functioning properly, if the vCenter appliance is exhibiting the behavior described above, you will still encounter the same error on the HCX Manager. If no issues are observed in the VM console and the VM is responding as expected, you can proceed further.

Verify that the HCX Manager can reach vCenter via the network.

  • From the HCX manager SSH access please run the following command to check the connectivity.
    • ping <vCenter_FQDN>
    • ping <vCenter_IP>
      • If the vCenter is not reachable via FQDN but is accessible via IP, you will need to continue troubleshooting the DNS configuration/connectivity in your environment.
    • curl -k -v https://<vCenter_FQDN>
    • curl -k -v https://<vCenter_IP>
      • If the vCenter is not reachable via the curl command, verify that the vCenter is up and running and there is no issue in accessing vCenter web GUI from your own system/laptop/jump box.
  • Note: Always ensure bidirectional reachability between vCenter and HCX. For more information, you can refer to the following KB article: Troubleshooting virtual machine network connection issues

Verify the user roles and permissions of the Logged In user

If there are no issues with vCenter or HCX Manager, and network reachability is confirmed, you can proceed to verify the user roles and permissions of the logged-in user. For more information on this, refer to the following KB article: Error loading Site Pairings Error: Unable to process HCX inventory details