Skyline Health displays "Unable to query vSAN health information. Check vSphere Client logs for details" error when navigating from Skyline Health alarm
search cancel

Skyline Health displays "Unable to query vSAN health information. Check vSphere Client logs for details" error when navigating from Skyline Health alarm

book

Article ID: 381246

calendar_today

Updated On:

Products

VMware vCenter Server 8.0

Issue/Introduction

When the alarm “Skyline Health has detected issues in your vSphere environment” is triggered, clicking [Actions] → [Learn more] from the alarm summary redirects to the Skyline Health page. However, this path displays the error:

“Unable to query vSAN health information. Check vSphere Client logs for details.”

But when navigating to Skyline Health manually via [Monitor] → [Skyline Health], the page loads correctly and displays the expected health information without any errors.

 

Error displayed when clicking [Lean more] from the summary page:

No error displayed when manually opened [Skyline Health] page:

Environment

vCenter Server 8.0

Cause

It's a known issue related to the UI code. It could happen even if the environment is not using vSAN.

Resolution

The engineering team is aware of this issue and the fix will be included in the next release.

Although this issue only affects UI functionality, we can simply avoid using the [Actions] -> [Learn more] menu for Skyline Health alarm and use Skyline Health by manually opening it from [Monitor] -> [Skyline Health].