SRM Protection Plan Fails to run with Netapp Snapmirror SRA error - "Unable to break the replication relationship of the device as a part of failover"
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Article ID: 381128
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Updated On:
Products
VMware Live RecoveryVMware Site Recovery Manager 8.x
Issue/Introduction
Customer is using storage based replication.
Storage solution is Netapp with Snapmirror as the storage replication.
When running a recovery plan, SRM reaches making the destination storage writable, then fails with an SRA error " SRA command 'failover' failed for device '//svm0/Volume0'. Unable to break the replication relationship of the device as a part of failover. Ensure that the SnapMirror relationship exists for the device and that the relationship status is either SnapMirrored or quiesced."
When checking the Snapmirror replication status on the Netapp side, the relationship is not quiesced.
Environment
VMware Site Recovery Manager 8.x
NOTE: While this issue was observed for a customer with SRM 8.5, the issue and workaround would apply to all versions where Snapmirror has not finished quiescing/breaking the replication.
Cause
This is an external issue with the Netapp Snapmirror replication. Before the destination storage can be accessed, Snapmirror must quiesce and then break the replication. There are various reasons this may not happen, and root cause would need to be identified by Netapp.
Resolution
Check the Netapp Snapmirror replication status (NetApp Docs - snapmirror show). Once the status shows quiesced, simply rerun the recovery plan in SRM. Note that this may require intervention from Netapp to get the storage replication into a quiesced state.