Error: "Unable to create Lookup Service gateway" while creating new replication in VMware Cloud Director Availability
search cancel

Error: "Unable to create Lookup Service gateway" while creating new replication in VMware Cloud Director Availability

book

Article ID: 381115

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • When creating a replication, a similar entry as below could be seen,
Error: Unable to create Lookup Service gateway
  • While reviewing the Lookup Service details on the VCDA Replicator appliance (under Service > System > Settings), we observed the following error: 'Unable to create Lookup Service Gateway'.

 

Environment

VMware Cloud Director Availability 4.x

Cause

VMware Cloud Director Availability not able to communicate with vCenter. This issue could occur when recent certificate updates or renewals have been made on the vCenter server.

Resolution

  • Log in to the VMware Cloud Director Availability (VCDA) UI and verify the vCenter URL
    (Note: This field is case-sensitive)

  • Re-apply the Lookup Service details in all the VMware Cloud Director Availability appliance (Replicator, Tunnel, Manger and Cloud) by navigating to Settings > Lookup Service Address

  • Click Edit, Accept the updated vCenter certificate (if applicable) and Save.