Aria Operations for Networks upgrade failed
search cancel

Aria Operations for Networks upgrade failed

book

Article ID: 381069

calendar_today

Updated On:

Products

VMware Aria Operations for Networks VMware vRealize Network Insight 6.x

Issue/Introduction

1. The upgrade for Aria Operations for Networks is failed with the error shown in the screenshot below:

2. The `centralized_upgrade.log` file includes the following exception: "Failed to get customer IDs" as illustrated in the screenshot below:

3. It is unable to fetch the "customer IDs" value from the config store, resulting in "customerID" appearing as null(=) in the RDB, as shown in the screenshot below:

 

4. The CustomerID state shows as expired, as shown in the screenshot below:

 

Environment

vRealize Network Insight 6.x
Aria Operations for Networks 6.10
Aria Operations for Networks 6.11
Aria Operations for Networks 6.12
Aria Operations for Networks 6.13
Aria Operations for Networks 6.14

Cause

The CustomerID state shows "expired" because the license for Aria Operations for Networks has expired, which caused the upgrade to fail.

 

Resolution

The upgrade for Aria Operations for Networks can be resumed after installing a new active license using the command line interface.

You can add the new license via the command line interface using the following commands:

SSH into Platform using a support account.

  • ub
  • rdb
  • customer_tool -m scan (This command will return customerID=xxxxx.)
  • customer_tool -cid <cid> -m add_license -license <KEY>
  • Example: customer_tool -cid 12874 -m add_license -license xxxxx-xxxxx-xxxxx-xxxxx-xxxxx