Aria Operations for Networks upgrade failed
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Aria Operations for Networks upgrade failed

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Article ID: 381069

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Updated On:

Products

VCF Operations for Networks

Issue/Introduction

1. The upgrade for Aria Operations for Networks is failed with the error shown in the screenshot below:

2. The `centralized_upgrade.log` file includes the following exception: "Failed to get customer IDs" as illustrated in the screenshot below:

3. It is unable to fetch the "customer IDs" value from the config store, resulting in "customerID" appearing as null(=) in the RDB, as shown in the screenshot below:

 

4. The CustomerID state shows as expired, as shown in the screenshot below:

 

Environment

Aria Operations for Networks 6.13.0
Aria Operations for Networks 6.14.0

Cause

The CustomerID state shows "expired" because the license for Aria Operations for Networks has expired, which caused the upgrade to fail.

 

Resolution

The upgrade for Aria Operations for Networks can be resumed after installing a new active license using the command line interface.

You can add the new license via the command line interface using the following commands:

  1. SSH into Platform using a support account.

    Execute below commands
    ub
    rdb
    customer_tool -m scan (This command will return customerID=xxxxx.)
    customer_tool -cid <cid> -m add_license -license <KEY>
    Example: customer_tool -cid 12874 -m add_license -license xxxxx-xxxxx-xxxxx-xxxxx-xxxxx

     

  2. Validate that the license now is seen on CLI , by executing below command
    customer_tool -m scan

    Executing above command should show the newly added license key.

  3. Validate that the license now is seen on GUI, by navigating to Settings>License and Usage.

  4. Once the GUI shows the license key the Upgrade should resume automatically in next 15-20 minutes.