Symantec Advanced Authentication PUSH Notification stop working on iOS upgrade
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Symantec Advanced Authentication PUSH Notification stop working on iOS upgrade

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Article ID: 380922

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Updated On:

Products

CA Risk Authentication CA Advanced Authentication CA Advanced Authentication - Strong Authentication (AuthMinder / WebFort) CA Strong Authentication

Issue/Introduction

The purpose of this KB article is to inform you of a recently identified problem with CA Mobile Authenticator App for Push notification. Error observed in the arcotafm.log is as follows

2024-10-28 09:52:06,053 [ajp-nio-127.0.0.1-8010-exec-7] ERROR aa.pns.PushNotificationService(188) [] -> Failed to notify device.
java.io.FileNotFoundException: https://fcm.googleapis.com/v1/projects/catechnologiesadvancedauth/messages:send
 at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1898) ~[?:1.8.0_402]

Environment

Symantec Advanced Authentication versions: 9.1, 9.1.01, 9.1.02, 9.1.03, 9.1.04, 9.1.5

Cause

CA Mobile Authenticator App, installed on Apple iPhones, that on upgrade to iOS version 17.6, 18 or above, CA Mobile Authenticator App stops receiving PUSH notifications.

Scenarios where the CA Mobile Authenticator App fails:

  • Existing Provisioned Accounts: These accounts function normally until the user forcefully closes and reopens the app.
  • New Provisioned Accounts Post-iOS 18.1 Upgrade: Similar to existing accounts, these accounts work until the app is forcefully closed.
  • Failure Case: If users forcefully close the app and then try to initiate the push notification flow, it will fail.

Resolution

Workaround Solution:

  1. If you have not upgraded your iOS version, please refrain from upgrading iOS till we have a new version of the mobile App which fixes this issue.
  2. If you have upgraded iOS, and PUSH notification is not working, choose another alternate credential, e.g. Mobile OTP from CA Mobile Authenticator App.
  3. The CA Mobile Authenticator App installed on Android mobiles continues to work fine.

The Symantec Advanced Authentication team worked on priority, we’re pleased to inform you that the push notification issue has been successfully resolved, and the refreshed CA Mobile Authenticator app has been uploaded to the App Store. As expected, the device ID remains unchanged when transitioning from the Beta to Production environment, ensuring smooth functionality without requiring re-enrollment.

Action Needed:

Please notify your users to update the CA Mobile Authenticator app from the App Store and verify the functionality on their devices.

Thank you for your patience and collaboration as we worked to resolve this issue. If you have questions, please contact Broadcom Support https://support.broadcom.com/.

Additional Information

https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/CriticalAlerts/0/25151