"No sensor data available" when accessing ESXi hardware health in Host Client and "No items found" in vCenter UI
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"No sensor data available" when accessing ESXi hardware health in Host Client and "No items found" in vCenter UI

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Article ID: 380862

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Updated On:

Products

VMware vSphere ESXi 8.0

Issue/Introduction

ESXi upgraded to 8.0 U2 and later version. 

Sensor information can be showed in the ESXi version of 8.0 U1 and earlier. 

When access ESXi Host Client under Monitor - Hardware - System Sensors prompt the message:

No sensor data available

In vCenter UI under Monitor - Hardware Health - SENSORS prompt the message:

No items found

Environment

VMware vSphere ESXi 8.0 Update 2 and later version

Cause

Previous in 8.0 U1 the IPMI driver was called 'ipmi' and looked up ACPI/SMBIOS/PCI to find out all the necessary memory locations for the drivers. Starting in 8.0 U2, the IPMI driver was renamed 'nipmi' and became a true ESXi device driver. Being a true device driver means the vmkernel performs the ACPI/SMBIOS/PCI lookup for the ipmi device driver and loads the device driver.

Resolution

To verify the issue:

  • The nipmi driver is not loaded:
    # vmkload_mod -l | grep -i nipmi
  • The IPI0001 device is not found from /var/run/log/boot:
    # grep -i IPI0001 boot

This is hardware firmware issue. Contact hardware vendor to get support.