Scanning with dmsweep shows existent machines as not managed
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Scanning with dmsweep shows existent machines as not managed

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Article ID: 380817

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

There are few available options that can be used to detect machines that required an Agent (non managed machines), as explained here:

Discover if all the machines in the environment have an agent

But when running dmsweep scan command, sometimes an existent machine is listed as non managed machine:

Environment

Client Automation 14.x

Cause

This behavior happens when scanned machines have an Agent, but no DM Primer installed.

Resolution

A possible workaround is to manually install DM Primer on existent Agent machines, as explained here:

Manual Installation of the Infrastructure Deployment Primer Software

Additional Information

dmsweep is the command line interface of DM Deployment Manager, which is used by Deployment Wizard, so it directly depends on DM Primer to get the required information, for installation and also for scan. 

When doing a scan using Deployment Wizard, it first tries to reach the machine using a ICMP echo request, if the machine responds, then it sends a CAM request through DM Primer queue, if it doesn't respond to that, then the machine is marked as "Machine responding", which means the machine is alive and responded the ICMP echo request, but didn't respond to CAM request through DM Primer queue. When this situation happens, it's not possible for Deployment Wizard or dmsweep determine if there is an Agent already installed or not.