Machine Fingerprint is malforming
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Machine Fingerprint is malforming

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Article ID: 38074

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Updated On:

Products

CA Rapid App Security CA Advanced Authentication CA API Gateway

Issue/Introduction

Issue:

Certain end users are unable to login because RiskMinder is unable to analyze the Machine Fingerprint.

Environment:
OS:Linux, Windows
CA Riskfort 3.x

Cause:

The cause is that 2.1 is not compatible with certain browser plugins, and browser versions, which can cause malformation of the DeviceDNA during the risk evaluation.

This can be due to using an older out-of-date Riskminder client which is the javascript component that creates the DeviceDNA used for the machine fingerprint. The Riskminder client that shipped with Riskfort 3.x was version 2.1 and is not compatible with all the latest browser version.

 

Resolution: 

To verify what version of the Riskminder client you are running.

(Tomcat Example)

 

<Tomcat Installation>\webapps\arcotafm\devicedna\riskminder-client.js

At the very bottom of the file there will be either be
                VERSION=\"2.1 or VERSION=\"2.1.2
It’s best to search the entire file for 2.1 and you will find the version immediately. The latest version of the Riskminder-Client is on the latest versions on the CA Risk Authentication, but can be used on Riskfort 3.x.

Should you have any of these problems with the DeviceDNA, such as specific users malforming the DeviceDNA, please open up a support ticket and we will provide you with the 2.1.2 Riskfort-Client.js.

The installation process is a drag and drop of where the old riskminder-client.js.

Environment

Release:
Component: RSKFRT