Large Status Reports time out on Export to PDF
search cancel

Large Status Reports time out on Export to PDF

book

Article ID: 380732

calendar_today

Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

When exporting a project Status Report, specifically a larger status report when it takes over 1:40, we can see it times out:

  • {
  •     "resourceId": null,
  •     "httpStatus": "500",
  •     "errorMessage": "EXP-01010: Error generating PDF export",
  •     "errorCode": "api.internalError"
  • }

ERROR 2024-10-10 12:34:27,853 [http-nio-8080-exec-1567] playwright.PWPooledObject (clarity:XXXXXXX:6787609__65806329-4104-4247-A612-501A63B8A2A5:PPM_REST_API) (36e61f40-7d8e-4bf9-be2a-b4046638b659) Timeout while waiting for loading page /project/5105195/status/5096112

ERROR 2024-10-10 12:34:27,912 [http-nio-8080-exec-1567] function.ExportAPI (clarity:XXXXXX:6787609__65806329-4104-4247-A612-501A63B8A2A5:PPM_REST_API) (36e61f40-7d8e-4bf9-be2a-b4046638b659) Export Exception:

com.ca.ppm.export.ExportException: api.export.01010

Smaller status reports export without any issue.

Environment

Any Supported Clarity Release 

Cause

Default PDF export timeout is 100 sec, any Status Report that is larger and it takes longer to generate may time out after 100 sec

Resolution

Important: This solution assumes correct environment setup and that internalUrl is set if appropriate. If this hasn't been checked, take a step back and verify it first: Status report export to PDF fails with Timeout

Increase timeout on PDF export to 2 min (120 sec). 

Only do this if confirmed needed by Broadcom Support. Note that allowing multiple large PDF exports may affect system performance so it is recommended to configure the Status Report Canvas with only the necessary fields

1.    Run the query on the Clarity database:
update cmn_option_values set value = 120000 where option_id=(select id from cmn_options where option_code='PLAYWRIGHT_NAVIG_TIMEOUT_OPT')
commit
2.    Restart all services