The CA Spectrum Discovery is not discovering all firewall models when they are configured in a primary/secondary or high availability setup.
search cancel

The CA Spectrum Discovery is not discovering all firewall models when they are configured in a primary/secondary or high availability setup.

book

Article ID: 38066

calendar_today

Updated On:

Products

CA Spectrum

Issue/Introduction

When discovering multiple devices using the CA Spectrum Autodiscovery tool, the Discovery step does not discover all models.  This happens especially when there are primary/secondary device configurations for high availability (HA).  The CA Spectrum Discovery results window will show the device that responded first to an SNMP query and it will not show/display the other (HA) device.

 

Environment

Release:
Component:

Cause

The reason the CA Spectrum Discovery tool does not show the HA device is due to both devices ip table having the same entries.  When the CA Spectrum discovery runs, if it finds two devices with the same ipAdEntAddr table, the discovery believes it has found a duplicate/same device and discards that device information.

Resolution

To work around this feature, you can manually create the HA device by navigating to the Topology view and manually modeling the device. You can use either the "Create New Model by Type" or the "Create New Model By IP" option.  Both options will allow you to create the HA device.  You may also need to manually create the connections to the other devices.  Since the original model has the connections, CA Spectrum may not create the connections for the HA device as it would then need to destroy the previous connections that were created for the original device model.  There is no way around this.