Unable to connect to SRM site pairs
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Unable to connect to SRM site pairs

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Article ID: 380606

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:

SRM UI display the below errors on launching the SRM DR UI page from VC:

Unable to retrieve pairs from extension server at https://[srmFQDN]:443/drserver/vcdr/vmomi/sdk.Unable to login to 'Site Recovery Manager Server at https://[srmFQDN]:443/drserver/vcdr/vmomi/sdk'.

 

We see a similar error message for session limit exceeded in dr.log:

2024-10-11 10:12:35,090 [srm-reactive-thread-1207] WARN  com.vmware.srm.client.infrastructure.requestHandlers.navigation.SitePairHelper 8367018482560015792 a1288380-ca60-497
3-891c-0df09a4100bf getDrSitePairs - Fail to get SRM sitePairData for SrmServerImpl {
_guid = 4497378e-bacb-4193-b227-0fe4cf16911c
_url = https://[srmFQDN]:443/drserver/vcdr/vmomi/sdk
}:
com.vmware.srm.client.topology.client.view.availability.ExtensionServer$GetPairFailedException: Unable to retrieve pairs from extension server at https://[srmFQDN]:443/drserver/vcdr/vmomi/sdk.Unable to login to 'Site Recovery Manager Server at https://[srmFQDN]:443/drserver/vcdr/vmomi/sdk'.
        at com.vmware.srm.client.topology.impl.view.availability.ExtensionServerImpl.complete(ExtensionServerImpl.java:51)
        at com.vmware.dr.ui.tools.reactive.impl.PromiseImpl$ErrorCompletion.complete(PromiseImpl.java:172)
        at com.vmware.dr.ui.tools.reactive.impl.PromiseImpl$Result.complete(PromiseImpl.java:43)
        at com.vmware.dr.ui.tools.reactive.impl.PromiseImpl$Completion.lambda$setResult$0(PromiseImpl.java:63)
        at com.vmware.dr.ui.tools.utilities.ThreadContext.lambda$wrap$1(ThreadContext.java:55)
        at com.vmware.dr.ui.tools.utilities.ThreadContext.execute(ThreadContext.java:209)
        at com.vmware.dr.ui.tools.utilities.ThreadContext.execute(ThreadContext.java:185)
        at com.vmware.dr.ui.tools.utilities.ThreadContext.setupContext(ThreadContext.java:76)
        at com.vmware.dr.ui.tools.utilities.ThreadContext.setupContext(ThreadContext.java:105)
        at com.vmware.dr.ui.tools.reactive.impl.PromiseImpl$Completion.lambda$setResult$1(PromiseImpl.java:63)
        at com.vmware.dr.ui.tools.utilities.AsyncConsumer$Worker.run(AsyncConsumer.java:38)
        at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
        at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
        at java.base/java.lang.Thread.run(Unknown Source)
Caused by: com.vmware.srm.client.topology.client.vmomi.Service$LoginFailedException: Unable to login to 'Site Recovery Manager Server at https://[srmFQDN]:443/drserver/vcdr/vmomi/sdk'.
        at com.vmware.srm.client.topology.impl.vmomi.vlsi.VmomiServiceImpl.lambda$doLogin$15(VmomiServiceImpl.java:484)
        at com.vmware.dr.ui.tools.reactive.impl.PromiseImpl$ComposeCompletion.complete(PromiseImpl.java:202)
        at com.vmware.dr.ui.tools.reactive.impl.PromiseImpl$Result.complete(PromiseImpl.java:41)
        ... 11 more
Caused by: (dr.fault.SessionLimitExceeded) {
   faultCause = null,
   faultMessage = null,
   limit = 90

 

 

Environment

VMware Site Recovery Manager 8.x
VMware Site Recovery Manager 9.x

Cause

External API calls by users to access SRM sessions are leading to rapid exhaustion of the session limit when sessions are not followed by a proper logout.

Resolution

To monitor and troubleshoot SRM session usage for specific users, you can track login and logout counts through logs:

      1. List of Users Logging into SRM: To view all users attempting to log into SRM, use the command:  grep 'Logging in SRM session' vmware-dr.log | less
      2. Track Login and Logout Counts for a Specific User: To get login and logout counts for a specific user (e.g., ontap_service): grep 'Logging in SRM session.*ontap_service' vmware-dr*.log | wc -l
      3. To get the Logout Count use the command: grep 'Logging out user.*ontap_service' vmware-dr*.log | wc -l
      4. Default SRM session limit count is 45. It can be configured in the file:  /opt/vmware/srm/conf/vmware-dr.xml

The issue isn't with SRM itself but stems from a third-party application that is leaving sessions open without properly logging out.