Error: "HTTP Error 500.19 - Internal Server Error" when using Service Desk Manager via Internet Information Server (IIS)

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Article ID: 38059

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service KNOWLEDGE TOOLS CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Problem: 

When using Service Desk Manager via Internet Information Server (IIS), the following error occurs:

HTTP Error 500.19 - Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid

Config Error: Cannot read configuration file due to insufficient permissions

Conf file bopcfg\www\wwwroot\web.config

 

Environment:  

Windows 2012 Server - Internet Information Server (IIS)

 

Cause: 

The identity set for the Application Pool being used is not correct, causing this issue to occur.

 

Resolution/Workaround:

1. Open IIS Manager

2. Expand Sites

3. Right-Click on CAisd > Manage Application > Advanced Settings

4. Take note of the application Pool. It should be DefaultAppPool

5. Close the Window

6. Go to Application Pools in Right Pane

7. Right-click on DefaultAppPool and advanced Settings

8. Set identity to LocalSystem > OK

9. Restart IIS 

10. Verify that the issue no longer happens now.

 

 

Environment

Release: SDMU0M99000-14.1-Service Desk Manager-Full License
Component: