Error: "HTTP Error 500.19 - Internal Server Error" when using Service Desk Manager via Internet Information Server (IIS)
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Error: "HTTP Error 500.19 - Internal Server Error" when using Service Desk Manager via Internet Information Server (IIS)

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Article ID: 38059

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

When Service Desk Manager (SDM) is configured to use Internet Information Server (IIS) web server, when attempting to access the SDM UOI, the following error occurs:

HTTP Error 500.19 - Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid

Config Error: Cannot read configuration file due to insufficient permissions

Confg file bopcfg\www\wwwroot\web.config 

Environment

CA Service Management  17.x

 

Cause

The identity set for the IIS Application Pool being used is not correct, causing the error to occur

Resolution

1. Open IIS Manager

2. Expand Sites

3. Right-click on CAisd -> Manage Application -> Advanced Settings

4. Take note of the Application Pool. It should be set to DefaultAppPool

5. Close the Window

6. Go to Application Pools in the right-hand pane and right-click on DefaultAppPool -> Advanced Settings

7. Set identity to LocalSystem  and click OK

8. Restart the IIS service

9.  Clear web browser cache and access the SDM UI via the SDM IIS URL and verify that the error no longer appears.