Unable to "check-in" VMs to a Content Library where the VM is backed by vVOL or vSAN ESA.
Checking in the VM fails with the error "The virtual disk is either corrupted or not a supported format".
The following log signature is seen in vCenter - /var/log/vmware/vpxd/vpxd.log
YYYY-MM-DDTHH:MM:SS info vpxd[06289] [Originator@6876 sub=VmProv opID=###] Workflow context:
--> (vpx.vmprov.CheckinContext) {
--> cbData = (vmodl.KeyAnyValue) [
--> (vmodl.KeyAnyValue) {
--> key = "workflow.startTime",
--> value = 2230646785562
--> },
--> (vmodl.KeyAnyValue) {
--> key = "workflow.actionTiming",
--> value = (vmodl.KeyAnyValue) [
--> (vmodl.KeyAnyValue) {
--> key = "vpx.vmprov.RemoveSnapshot",
--> value = "YYYY-MM-DDTHH:MM:SS.328692Z"
--> },
--> (vmodl.KeyAnyValue) {
--> key = "vpx.vmprov.PromoteDisks",
--> value = "YYYY-MM-DDTHH:MM:SS.356588Z"
--> }
--> ]
--> }
--> ],
--> checkinSpec = (vim.vm.CheckinSpec) {
--> snapshotName = "snapshot-name",
--> snapshotDescription = "Snapshot used by Content Library to check out a library item containing a virtual machine template.",
--> contentLibItemInfo = (vim.vm.ContentLibraryItemInfo) {
--> contentLibraryItemUuid = "###",
--> contentLibraryItemVersion = "3"
--> },
--> previousTemplate = 'vim.VirtualMachine:###:vm-###',
--> previousTemplateNewName = "template-name",
--> currentTemplateName = "template-name"
--> },
--> vm = 'vim.VirtualMachine:###:vm-###',
--> }
YYYY-MM-DDTHH:MM:SS error vpxd[06289] [Originator@6876 sub=Default opID=###] [VpxLRO] -- ERROR lro-80681188 -- ### -- vm-### -- vim.VirtualMachine.checkin: :vim.fault.InvalidDiskFormat
--> Result:
--> (vim.fault.InvalidDiskFormat) {
--> faultCause = (vmodl.MethodFault) null,
--> faultMessage = <unset>
--> msg = "The virtual disk is either corrupted or not a supported format."
--> }
--> Args:
-->
--> Arg spec:
--> (vim.vm.CheckinSpec) {
--> snapshotName = "snapshot-name",
--> snapshotDescription = "Snapshot used by Content Library to check out a library item containing a virtual machine template.",
--> contentLibItemInfo = (vim.vm.ContentLibraryItemInfo) {
--> contentLibraryItemUuid = "###",
--> contentLibraryItemVersion = "3"
--> },
--> previousTemplate = 'vim.VirtualMachine:###:vm-###',
--> previousTemplateNewName = "template-name",
--> currentTemplateName = "template-name"
--> }
YYYY-MM-DDTHH:MM:SS warning vpxd[06289] [Originator@6876 sub=Vmomi opID=###] VMOMI activation LRO###, <TCP '127.0.0.1 : 8085'>, <TCP '127.0.0.1 : 45150'>>, vm-###, vim.VirtualMachine.checkin, <vim.version.v8_0_3_0, internal, 8.0.3.0>, (null)>, N3Vim5Fault17InvalidDiskFormat9ExceptionE(Fault cause: vim.fault.InvalidDiskFormat
--> )
The Content Library service explicitly disables the disk promotion (promoteDisks) workflow for disks that support native snapshots.
This is an expected architectural behavior in vVols and vSAN ESA environments whose disks support native snapshots which can't be disabled.
There is no direct workaround available to force this workflow on vSAN ESA.
Subscribe to this article to receive alerts on future updates: Subscribe to a Broadcom knowledge article by article or product